Bug #1091

1st person Laser weapon model not centered

Added by halogene over 2 years ago. Updated about 1 year ago.

Status:NewStart date:03/02/2012
Priority:NormalDue date:
Assignee:Morphed% Done:

0%

Category:Graphics
Target version:0.8

Description

adem4ik noticed that the 1st person laser weapon model is not centered anymore when using centered weapon models, it got moved a bit to the right.

http://forums.xonotic.org/showthread.php?tid=2676&pid=35745

History

#1 Updated by Morphed over 2 years ago

  • Status changed from New to Resolved
  • Assignee set to Morphed

fixed in morphed/laserfix branch, its wating for merge

#2 Updated by divVerent over 2 years ago

  • Status changed from Resolved to New

The fix broke a lot as it changed the animation type of the model. Reopening the issue. We need a h_ model that is properly centered, OR fixing the centering in the v_ model (no idea which is the uncentered one).

http://rghost.net/36832770

#3 Updated by C.Brutail over 2 years ago

  • Status changed from New to Resolved

Grunt also confirms it's fixed, me and asyyy couldn't reproduce the bug either as of today's git build.

#4 Updated by adem4ik about 2 years ago

Laser is still not centered. Morphed's fix wasn't merged?

#5 Updated by MrBougo about 1 year ago

  • Status changed from Resolved to New
  • Priority changed from Low to Normal
  • Target version set to 0.8

adem4ik reports the same issue in the 0.7 release. See the forum post.

Moreover, s/he reports the same problem with the crylink (see post above).

I'm reopening this issue as "New" instead of making a duplicate.

Also available in: Atom PDF