Bug #1097

Some unicode characters aren't translated in stripped_nick

Added by antibody over 2 years ago. Updated over 1 year ago.

Status:In ProgressStart date:03/04/2012
Priority:NormalDue date:
Assignee:antibody% Done:

50%

Category:Database
Target version:-

Description

Example: http://stats.xonotic.org/player/874. The 'G' is a unicode character, preventing him from being returned with a search using 'Gentnoob.' Searches without the 'G' return properly.

Associated revisions

Revision 8f9c0152
Added by zykure over 1 year ago

Resolve some issues with characters not being translated correctly, fixes #1097

History

#1 Updated by zykure over 1 year ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

Applied in changeset xonstat|commit:8f9c0152b1722dde4b5c6230328f971f9c436a05.

#2 Updated by zykure over 1 year ago

  • Category changed from Server Code to Database

This is still not fully resolved as search still doesn't work as expected.

I suspect this is a problem with the database (or its contents), not with the actual code of the website.
For example take a look at http://stats.xonotic.org/player/874.json - the "stripped_nick" field shows up as "\ue0c7entnoob". This means although stripped_nick should only contain ASCII characters (i.e. after conversion by qfont_decode, see source:xonstat|xonstat/util.py#L68), it contains some other characters as well.
Commit 8f9c0152 fixes this for some objects by applying qfont_deocode another time, before returning the string. However, this doesn't work in the search itself since that's using a SQL query, and thus works directly on the database contents.

Maybe the easiest solution would be to write a small script that applies qfont_decode to all existing entries?

Also available in: Atom PDF