Bug #1184

Xonotic disables Wi-Fi (OSX)

Added by bloodshinoda over 2 years ago. Updated about 2 years ago.

Status:ResolvedStart date:04/27/2012
Priority:HighDue date:
Assignee:-% Done:

100%

Category:Engine
Target version:0.6

Description

When Xonotic is started, wi-fi goes down... Happens on OSX 10.5.6, 10.6.8 and 10.7.3... This same bug exists on the old Nexuiz as well...

History

#1 Updated by bloodshinoda about 2 years ago

Does someone know a solution for that? Today i've experienced it again and realized that the game messes with all the network, when on Wi-Fi... Making other computers offline too... (This time, under WINDOWS...)

#2 Updated by Spaceman about 2 years ago

Which version of Xonotic and what type of router / wireless device are you using?

#3 Updated by divVerent about 2 years ago

It sure is no bug in Xonotic, as no software, no matter how buggy, can crash a working router. Shutting down/rebooting/disconnecting a working router after all requires at the very least the password to its configuration system...

However, this doesn't mean it can't be possibly worked around. The general idea is to make Xonotic send packets less often. This will decrease gameplay experience, but may work around the router crashes.

Try: cl_netfps 30, and net_slist_queriespersecond 5.

But what I really recommend is upgrading the router firmware, and if that doesn't help, using your rights as a customer to get the router fixed or replaced by a working one.

I am keeping this ticket open for now, but will close it later, as it is clearly not a bug in Xonotic. Please respond whether any of these fixed your problem.

#4 Updated by bloodshinoda about 2 years ago

0.6 release, the router is a D-Link DIR-651...

It happens also in other routers, TP-Link's and NetGear...

#5 Updated by bloodshinoda about 2 years ago

SOLVED... (Less packets...)

#6 Updated by doomsknight about 2 years ago

So what was the solution then? Can this be closed or is something still required?

#7 Updated by bloodshinoda about 2 years ago

Less packets, reducing net speed and the "queries per second" solved that.... Thanks!

#8 Updated by tZork about 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF