Bug #1215

'Lightspeed' appears unplayable when OpenGL 2.0 is disabled/not available

Added by doomsknight almost 2 years ago. Updated 4 months ago.

Status:NewStart date:05/14/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Maps
Target version:0.8

Description

When playing Lightspeed (as a local game in this case), the map appeared all black with player models rendered unusually (screenshot attached). This is unplayable. All other standard maps appear fine. Having checked for errors, then looked at config. vid_gl20 0 is used on this older system (2x1GHz P3, Geforce FX5600 NVIDIA driver under Arch Linux) to improve performance. Having reenabled vid_gl20 1 and done a vid_restart the map renders correctly again (screenshot attached). Disabling OpenGL 2.0 again causes the same problem again.

Not tested on other systems at this point to confirm.

I believe this may be down to glow maps being required by this map for textures. If we could instead have a basic flat texture underneath this would work correctly without OpenGL 2.0. Otherwise OpenGL 1.x support would have to be dropped for the game to include a map that requires glowmaps.

xonotic20120514223253-00.jpg (91.3 KB) doomsknight, 05/14/2012 11:47 pm

xonotic20120514223405-00.jpg (60.1 KB) doomsknight, 05/14/2012 11:47 pm

365
366

History

#1 Updated by divVerent almost 2 years ago

These have no glow maps. The cause is something different - but what?

#2 Updated by Mirio 11 months ago

  • Category set to Maps
  • Assignee set to Mirio
  • Target version set to 0.8

#3 Updated by Mirio 4 months ago

  • Assignee deleted (Mirio)

Also available in: Atom PDF