Bug #1237

Server crash in current autobuild

Added by rafallus almost 2 years ago. Updated almost 2 years ago.

Status:ResolvedStart date:06/02/2012
Priority:UrgentDue date:
Assignee:tZork% Done:

100%

Category:-
Target version:-

Description

I'm not sure if there are relevant logs somewhere, but I've seen dump in console so I'll attach screenshots Those crashes are pretty frequent in fact.

xonotic20120602234204-00.jpg (220 KB) rafallus, 06/02/2012 11:46 pm

xonotic20120602234209-00.jpg (218 KB) rafallus, 06/02/2012 11:46 pm

2012-06-08_22-09_final_rage.dem (1.1 MB) rafallus, 06/08/2012 10:26 pm

items_crash.log (320 KB) rafallus, 06/09/2012 11:24 am

368
369

History

#1 Updated by divVerent almost 2 years ago

  • Assignee set to tZork
  • Priority changed from Urgent to Normal

The first one is a bug in code not yet committed. Autobuilds don't contain it either. However, the server was running the code in question.

The second one might be related to that too. Was it the same server?

I assigned this to tZork who is working on that code.

#2 Updated by rafallus almost 2 years ago

I may not been clear enough - both of those screenshots refer to the same crash - it's that dump took up so much, that ending with statement numbers didn't fit in one console width, hence 2 shots.

Bug happens around 1 in 3 local games. Double checked now - it happens in campaign too.

#3 Updated by divVerent almost 2 years ago

  • Priority changed from Normal to Urgent

Ah, I see now, "simple items" are in master now since Jun 1. I had missed that.

tZork: that makes these bugs urgent. At least the trace looks like it should help tracking it down.

#4 Updated by tZork almost 2 years ago

Any information on how to provoke this crash?

#5 Updated by tZork almost 2 years ago

Also traces say its a client crash, did the server also crash or is the topic just wrong? :P

#6 Updated by rafallus almost 2 years ago

Entire client didn't crash, I was still able to start a new game again. But of course the game played was lost.

It happens around 1 in 3 times in local games (instant action/create). I managed to reproduce it on a final level of campaign (glowplant).

#7 Updated by tZork almost 2 years ago

How did you reproduce it? that is what i need to know. No matter what i try i get no crashing.

#8 Updated by rafallus almost 2 years ago

OK:

-The more players there are on the server, the faster I get it (with 9 bots it usually happens within 2 minutes),
-Crash seems to be happen when many players get fragged within short time - I once had it after getting 3 frags with one shot. Other time I got it by fragging a bot. Looking at console, it showed that two bots managed to frag other bots just in the meantime, within a really short time frame.
I don't know if they matter, but recently changed settings:
-motion blur enabled (=1.0), that means disabled AA and r_viewfbo 3,
-cl_simple_items doesn't matter, crashed both with 0 and 1.

Tried to record a demo, but can't, apparently it's not saved on crash.

#9 Updated by rafallus almost 2 years ago

Nevermind, must have done sth wrong last time, this time demo recorded. Game ended with crash, map: final_rage

#10 Updated by tZork almost 2 years ago

That demo does not show anything significant as far as i can see. Hm. I smashed bots on that map for 2 hrs straight and nothing.

Could you try this:

prvm_backtraceforwarnings 1
developer 1
log_file "items_crash.log"
bot_number 7
map glowplant

then play until it crash, and attach that log here.

#11 Updated by rafallus almost 2 years ago

Sure enough, got that on a first attempt, within 4-5 minutes (which still is a bit longer than usual).

#12 Updated by tZork almost 2 years ago

There is a partial fix for this in master, plz try tomorrows autobuild and see if the crash still happens. Watch out for lines like
"^7^1Tried to spawn !#%'n Tuba with no model!" (not necessarily "!#%'n Tuba")
in the console/log. If you see that, it means the crash has be prevented.

#13 Updated by tZork almost 2 years ago

  • Status changed from New to Feedback

#14 Updated by tZork almost 2 years ago

  • Status changed from Feedback to Resolved

#15 Updated by rafallus almost 2 years ago

I have not managed to reproduce a crash since current autobuild, but I now have tons of "/models/players/modelname not found" messages and all player models are forced to Erebus, regardless of which is chosen in menu (with wrong taunts). I don't know if it's related.

#16 Updated by tZork almost 2 years ago

I dont see how it can be related, items and players are separate code paths.

Also available in: Atom PDF