Feature #1285

Followpowerup command

Added by asyyy almost 2 years ago. Updated about 1 year ago.

Status:ResolvedStart date:08/16/2012
Priority:NormalDue date:
Assignee:tZork% Done:

100%

Category:-
Target version:1.0

Description

Executing the followpowerup command should allow specs to cycle through players who have picked up a powerup (e.g. strength). If no player carries a powerup, the followpowerup command has no effect.
This command is especially useful for streamers of large team games (e.g. 4v4 tdm or 5v5 ctf).

History

#1 Updated by tZork almost 2 years ago

  • Status changed from New to Feedback
  • Assignee set to tZork
  • Target version set to 1.0

Added some simple things as a mutator.

Server needs to be git/autobuild and have: g_superspectate 1
Commands work via the cmd interface, thise are the currently supported commands:
followpowerup: Find & spectate any player with a powerup (strength or shield)
followstrength Find & spectate ant player with strength
followstshield Find & spectate ant player with shield
followfc Find and spectate a flag carrier, can take an optional argument of red or blue to find a specific FC

#2 Updated by asyyy almost 2 years ago

The followpowerup command works, but with g_superspectate 1 many commands stopped working, e.g. lsmaps, vcall, say (after joining a team) and spectate.

#3 Updated by tZork almost 2 years ago

Heh sometimes true is false ;) should be working as intended in master now.

#4 Updated by asyyy almost 2 years ago

I think this can be closed? Seems to work flawlessly.

#5 Updated by Mirio about 1 year ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF