Bug #1295

NetRadiant mouse freezes. Can't edit maps bc of this.

Added by MayEpper almost 2 years ago. Updated over 1 year ago.

Status:ResolvedStart date:08/30/2012
Priority:HighDue date:
Assignee:-% Done:

100%

Category:Netradiant
Target version:-

Description

Using trackpad onlaptop with netradiant impossible now:
When moving around when pressing the right button and moving finger on the trackpad often it freezez and then warps you to way far away. Happens in both the 2d and 3d views. This makes radiant impossible to use due to these freezes and warps.

Easiest to trigger by creating a box, keeping it selected and then trying to drag your view around.

3.5 kernel, HP Laptop, debian. 64bit
Used to work fine.

Tried xset m 1 for no mouse acceletarion (and xset m 0 but that didn't do anything :P) Bug still there.

NetRadiant was rock solid :(, for so long, now can't use it anymore :(

History

#1 Updated by MayEpper almost 2 years ago

Tried older kernel, still have this "warp to 42000 qu away" bug. It first freezes when you have one finger depressing the right mouse button and one on the trackpad. It then warps thousands of qunits away once you release your hold on the right trackpad mouse button.

Happens mainly with the window that shows X and Y, and also the 3d viewport (there it freezes and then makes you looks straight up (Z). seemed at first.

Was wrong, happens in other views once you select something and then move the view around.

Doesn't happen with regular mouse.

#2 Updated by MayEpper almost 2 years ago

Tried this:
synclient CoastingSpeed=0
and
synclient TapAndDragGesture=0

neither helped.

I get warped all over the place with the trackpad.

#3 Updated by MayEpper almost 2 years ago

Disabled this aswell:
synclient | grep VertTwoFingerScroll
VertTwoFingerScroll = 1
synclient | grep HorizTwoFingerScroll
HorizTwoFingerScroll = 0
synclient VertTwoFingerScroll=0

Also did't work!
Trackpad Mouse still freezes (and then when you release the right click button) warps to end or 1/2 end of map when working with the touchpad :(

#4 Updated by MayEpper almost 2 years ago

Turning off synaptics makes netrad work well again.

#5 Updated by Samual over 1 year ago

  • Category set to Netradiant

#6 Updated by Samual over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF