Feature #636

Make the physics panel have more obvious and visible information

Added by Samual over 2 years ago. Updated 11 months ago.

Status:ResolvedStart date:09/03/2011
Priority:LowDue date:
Assignee:terencehill% Done:

100%

Category:HUD
Target version:0.7

Description

As many have said on the forums, they simply cannot understand/see the new physics panel design (for acceleration) as well as the previous one -- Though it looks good and has many useful features, it also needs a simplified version or simply better layout/graphics so that it can be understood by normal users more easily.

Personally though, I have no issue with it as is.. and would not like to lose any of the functionality it provides... Just, perhaps make a larger version of the panel or some better display for it?

Anyway, not important at the moment, but something to think about. If anything, make sure to check out the thread and ask them questions on any progress we make to see what they think: http://forums.xonotic.org/showthread.php?tid=2100

History

#1 Updated by terencehill over 2 years ago

For the physics panel there are already some cvars good to configure the layout in every aspect, I added them as per request by FruitieX just to meet wishes of those players who want to see speed and acc like before:

hud_panel_physics_progressbar "1" "enable progressbar in panel (2 = only for speed; 3 = only for acceleration)"

hud_panel_physics_acceleration_progressbar_mode "0" "0 = progressbar increases from the center to the right if the acceleration is positive, to the left if it's negative; 1 = progressbar increases from the border in the same direction for both positive and negative accelerations"

hud_panel_physics_text "1" "show text in panel (2 = only for speed; 3 = only for acceleration)"

To reproduce the old layout (taken from hud_nexuiz.cfg skin):
hud_panel_physics_progressbar 3
hud_panel_physics_acceleration_progressbar_mode 0
hud_panel_physics_text 2

Sadly controls for these cvars aren't present in the menu due to lack of space :(
Maybe we can replace vertical acc and speed checkboxes with hud_panel_physics_progressbar and hud_panel_physics_text sliders... don't know, they might be useful for more users.

#2 Updated by terencehill over 2 years ago

Another "limitation" the physics panel has is that acc and speed "fields" can't be always long as the panel width; if the panel is too stretched horizontally (aspect ratio > 4:1) the fields are put one on the left, the other one on the right.

We can override this limitation by adding another cvar, something like:
hud_panel_physics_split_mode "define how to split fields: 0 automatically, based on the panel aspect ratio, 1 horizontally, 2 vertically"

OT: we can also easily extend this feature to healtharmor and powerups panels, as they work in the same way.

#3 Updated by ItsMe over 2 years ago

i guess a cvar like
hud_panel_physics_acceleration_scale
to allow scaling the acceleration progress bar

#4 Updated by terencehill over 2 years ago

ItsMe wrote:

i guess a cvar like
hud_panel_physics_acceleration_scale
to allow scaling the acceleration progress bar

Let the acc progressbar go beyond the panel limits is a dirty thing I don't like particularly, but actually... it's less complex and should work better than my idea. All in all I agree with you, let's see what Samual thinks about it.

#5 Updated by terencehill over 2 years ago

  • Status changed from New to Feedback

But it'd partially cover the speed if the acc. is on the left/right of the speed... so maybe in this case we should not make work the scale cvar.
Due to the hackish nature of this cvar we should not show it in the menu though.

#6 Updated by Samual about 1 year ago

  • Target version changed from Later to 0.8

#7 Updated by terencehill 11 months ago

  • Status changed from Feedback to Resolved
  • Target version changed from 0.8 to 0.7
  • % Done changed from 0 to 100

Long time ago I added some other cvars to configure the physics panel in nearly every aspect, it's now possible to make it look like the pre-panel stuff.

Also available in: Atom PDF